TOYS POJ - 2318(叉乘的应用+二分)

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

思路:因为隔板是按顺序给的,利用点和隔板的叉积关系可以判断点在隔板的左测还是右侧。

可以暴力写,也可以二分写,二分要注意取的是第一个满足的,所以取l

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
typedef long long ll;
#define INF 0x3f3f3f3f
const int maxn=1e5+5;
const int MAXN=1e3+10;
const long long mod=100000000;
using namespace std;
const double eps=1e-8;
const double PI=acos(-1.0);
int ans[maxn];
struct point
{
	int x,y;
    point(int a=0,int b=0):x(a),y(b){}
    int operator^(const point a) const
    {
        return x*a.y-y*a.x;
    }
    point operator-(const point &b) const
    {
        return point(x-b.x,y-b.y);
    }
}p[maxn],b[maxn],d[maxn];
int main(int argc, char const *argv[])
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    int n,m,x1,y1,x2,y2;
    while(scanf("%d%d%d%d%d%d",&n,&m,&x1,&y1,&x2,&y2)!=EOF&&n)
    {
        p[0].x=x1,p[0].y=y1,p[1].x=x2,p[1].y=y2;
        for(int i=0;i<n;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            b[i].x=u,b[i].y=y1;
            d[i].x=v,d[i].y=y2;
            ans[i]=0;
        }
        ans[n]=0;
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int j=0;
            for(j=0;j<n;j++)
            {
                if(((point(x,y)-d[j])^(b[j]-d[j]))<=0)
                {
                    break;
                }
            }
            ans[j]++;
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,ans[i]);
        }
        printf("\n");
    }

    return 0;
}

二分:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
typedef long long ll;
#define INF 0x3f3f3f3f
const int maxn=1e5+5;
const int MAXN=1e3+10;
const long long mod=100000000;
using namespace std;
const double eps=1e-8;
const double PI=acos(-1.0);
int ans[maxn];
struct point
{
	int x,y;
    point(int a=0,int b=0):x(a),y(b){}
    int operator^(const point a) const
    {
        return x*a.y-y*a.x;
    }
    point operator-(const point &b) const
    {
        return point(x-b.x,y-b.y);
    }
}p[maxn],b[maxn],d[maxn];
bool check(point a,point bb,point c)
{
    return ((a-c)^(bb-c))<0;
}
int main(int argc, char const *argv[])
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    int n,m,x1,y1,x2,y2;
    while(scanf("%d%d%d%d%d%d",&n,&m,&x1,&y1,&x2,&y2)!=EOF&&n)
    {
        p[0].x=x1,p[0].y=y1,p[1].x=x2,p[1].y=y2;
        for(int i=0;i<n;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            b[i].x=u,b[i].y=y1;
            d[i].x=v,d[i].y=y2;
            ans[i]=0;
        }
        ans[n]=0;
        for(int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            int l=0,r=n-1,s=0;
            while(l<=r)
            {
                int mid=(l+r)>>1;
                if(check(point(x,y),b[mid],d[mid]))
                {
                    r=mid-1;
                }
                else
                {
                    l=mid+1;
                }
            }
            if(l<n&&check(point(x,y),b[l],d[l]))
            {
                ans[l]++;
            }
            else
            {
                if(l==n) ans[n]++;
                else ans[++l]++;
            }
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,ans[i]);
        }
        printf("\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40774175/article/details/81913944