POJ 2318 TOYS (叉积+二分)

题目:

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

题意:给出一个矩形盒子 给出数条线段作为隔断 向盒子内放物品 判断每个区域内物品数量
思路:每输入一个物品位置 都二分查找隔断 利用叉积判断是在隔断的左侧还是右侧

代码如下:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int inf=0x3f3f3f3f;
const int maxn=5050;
int ans[maxn];
int n,m,x,y,xx,yy,tx,ty,U,L;

struct Point{
    int x,y;
    Point(){}
    Point(int _x,int _y){
        x=_x,y=_y;
    }
    Point operator + (const Point &b) const {
        return Point(x+b.x,y+b.y);
    }
    Point operator - (const Point &b) const {
        return Point(x-b.x,y-b.y);
    }
    int operator * (const Point &b) const {
        return x*b.x+y*b.y;
    }
    int operator ^ (const Point &b) const {
        return x*b.y-y*b.x;
    }
};

struct Line{
    Point s,e;
    Line(){}
    Line(Point _s,Point _e){
        s=_s,e=_e;
    }
}line[maxn];

int xmult(Point p0,Point p1,Point p2){
    return (p1-p0)^(p2-p0);
}

int main(){
    while(scanf("%d",&n)==1 && n){
        scanf("%d%d%d%d%d",&m,&x,&y,&xx,&yy);
        for(int i=0;i<n;i++){
            scanf("%d%d",&U,&L);
            ans[i]=0;
            line[i]=Line(Point(U,y),Point(L,yy));
        }
        line[n]=Line(Point(xx,y),Point(xx,yy));
        Point p;
        memset(ans,0,sizeof(ans));
        while(m--){
            scanf("%d%d",&tx,&ty);
            p=Point(tx,ty);
            int l=0,r=n;
            int tmp;
            while(l<=r){
                int mid=(l+r)>>1;
                if(xmult(p,line[mid].s,line[mid].e)<0){
                    tmp=mid;
                    r=mid-1;
                }
                else l=mid+1;
            }
            ans[tmp]++;
        }
        for(int i=0;i<=n;i++) printf("%d: %d\n",i,ans[i]);
        printf("\n");
    }
    return 0;
}
 
 
 

猜你喜欢

转载自www.cnblogs.com/whdsunny/p/9836416.html