poj2318 TOYS && poj2398 Toy Storage

由于这两道题是同一道题,只有略微不同,就一块写啦

poj2318   TOYS

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

思路:

暴力即可,只是需要判断玩具是 在隔板的左边还是右边

代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#define ll long long
using namespace std;
struct Pt
{
    int x1,x2;
}a[5005];
int ans[5005];
bool det(Pt a,Pt b)
{
    return (a.x1 * b.x2 - b.x1 * a.x2) > 0 ? 0 : 1;
}
int main()
{
    int n,m,x1,y1,x2,y2,x,y;
    while (~scanf("%d",&n) && n)
    {
        memset(ans,0,sizeof(ans));
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        for (int i = 0;i < n;i ++)
            scanf("%d %d",&a[i].x1,&a[i].x2);
        for (int i = 0;i < m;i ++)
        {
            int j;
            scanf("%d %d",&x,&y);
            for (j = 0;j < n;j ++)
            {
                Pt p1,p2;
                p1.x1 = a[j].x1 - x,p1.x2 = y1 - y;
                p2.x1 = a[j].x2 - x,p2.x2 = y2 - y;
                if (det(p1,p2))
                {
                    ans[j] ++;
                    break;
                }
            }
            if (j == n) ans[n] ++;
        }
        for (int i = 0;i <= n;i ++)
            printf("%d: %d\n",i,ans[i]);
        putchar('\n');//此处需要注意把这个不要跟上面的输出写一起,否则PE;
    }
    return 0;
}

poj2398 

Toy Storage

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

思路:

这道题跟上面不同的是他的隔板是错序的,排下序即可,另外输出的也不同,注意即可

代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#define ll long long
using namespace std;
struct Pt
{
    int x1,x2;
}a[5005];
int ans[5005];
bool det(Pt a,Pt b)
{
    return (a.x1 * b.x2 - b.x1 * a.x2) > 0 ? 0 : 1;
}
bool cmp(Pt a,Pt b)
{
    return a.x1 < b.x1;
}
int main()
{
    int n,m,x1,y1,x2,y2,x,y;
    while (~scanf("%d",&n) && n)
    {
        memset(ans,0,sizeof(ans));
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        for (int i = 0;i < n;i ++)
            scanf("%d %d",&a[i].x1,&a[i].x2);
        sort(a,a + n,cmp);
        for (int i = 0;i < m;i ++)
        {
            int j;
            scanf("%d %d",&x,&y);
            for (j = 0;j < n;j ++)
            {
                Pt p1,p2;
                p1.x1 = a[j].x1 - x,p1.x2 = y1 - y;
                p2.x1 = a[j].x2 - x,p2.x2 = y2 - y;
                if (det(p1,p2))
                {
                    ans[j] ++;
                    break;
                }
            }
            if (j == n) ans[n] ++;
        }
        map<int,int> mp;
        for (int i = 0;i <= n;i ++)
        {
            if(ans[i]) mp[ans[i]] ++;
        }
        map<int,int> :: iterator it;
        printf("Box\n");
        for (it = mp.begin();it != mp.end();it ++)
        {
            int p1 = it -> first,p2 = it -> second;
            printf("%d: %d\n",p1,p2);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81227910