POJ1068

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:


        S              (((()()())))


        P-sequence         4 5 6666


        W-sequence         1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2

6

4 5 6 6 6 6

9

4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

用相邻的括号数做差,看可以匹配几次,详细看代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int main()
{
	int t;
	int n;
	int p[21],q[21],d[21],mark[21];//p存左括号的值,q存右括号,d是p[i]-p[i-1],mark是两次d被用了几次
	cin>>t;
	while(t--) {
		cin>>n;
		int first(0),later(0);
		for(int i=0; i<n; i++) {
			cin>>p[i];
			later=p[i];
			d[i]=later-first;
			first=p[i];
		}
		memset(mark,0,sizeof(mark));
		for(int i=0;i<n;i++){
			q[i]=1;
		}
		int i=0;
		for(i=0; i<n; i++) {
			if(d[i]==0) {
				int t=i;
				int ans=0;
				while(d[t]==0||mark[t]==d[t]) {
					ans+=mark[t];
					t--;
				}
				while(mark[t]+1==d[t]) {
					mark[t]++;
					ans+=mark[t];
					t--;
					while(d[t]==0||mark[t]==d[t]) {
						ans+=mark[t];
						t--;
					}
				}
				mark[t]++;
				q[i]=ans+mark[t]+1;
			}
		}
		for( i=0;i<n;i++){
			cout<<q[i];
			if(i<n-1)	cout<<" ";
			else	cout<<endl;
		}
	}
}

先将p转换成括号,再将括号转换成q,运用到了stack

使用stack,将p序列还原成括号序列

将左括号记为1,压入栈,扫到右括号,弹出栈顶元素,将新的栈顶元素加上已扫到的右括号的数目,

弹出数字序列即为w序列

#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main()
{
    int n;
    cin >> n;
    for (int i=0; i<n; i++)
    {
        int m;
        cin >> m;
        string str;
        int leftpa = 0;
        for (int j=0; j<m; j++)
        {
            int p;
            cin >> p;
            for (int k=0; k<p-leftpa; k++) str += '(';
            str += ')';
            leftpa = p;
        }
        stack<int> s;
        for (string::iterator it=str.begin(); it!=str.end(); it++)
        {
            if (*it=='(')
                s.push(1);
            else
            {
                int p = s.top(); s.pop();
                cout << p << " ";
                if (!s.empty()) s.top() += p;
            }
        }
        cout << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41667282/article/details/81347244