POJ 1068

Parencodings

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28491   Accepted: 16786

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 

	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001

扫描二维码关注公众号,回复: 3364409 查看本文章

大致题意:

一个括号表达式可以按照如下的规则表示,就是每个右括号之前的左括号数。
比如(((()()()))),每个右括号之前的左括号数序列为P=4 5 6 6 6 6,而每个右括号所在的括号内包含的括号数为W=1 1 1 4 5 6.
现在给定P,输出W。

解题思路:

先根据P还原整个括号表达式,存在数组中,然后递归解出W..

代码:

#include<iostream>  
using namespace std;  
char y[10000];  int p[50],w[50],n,l,j;  //y为还原后的括号
int f()  
{  
    int s=1;  //消除之前的连续左括号对结果的影响
    while(1)  
        if(y[j]=='(')  //若是左括号,继续递归求解
        {  
            j++;  
            s+=f();  
        }  
        else  //若是右括号,将已有括号数写入W
        {  
            w[l++]=s;  
            j++;  
            return s;  
        }  
}  
int main()  
{  
    int t,i,k;  
    cin>>t;  //例子个数
    while(t--)  
    {  
        cin>>n;  //右括号个数
        for(i=0,l=0,k=0;i<n;i++)  
        {  
            cin>>p[i];  //输入P
            for(j=0;j<p[i]-k;j++)  //每个右括号前的左括号加入序列
                y[l++]='(';  
            y[l++]=')';  //加入此次右括号
            k=p[i];  //之前加过的左括号去掉,以免重复
        }  
        l=j=0;  
        f();  
        for(i=0;i<n;i++)  
            cout<<w[i]<<' ';  
        cout<<endl;  
    }  
    return 0;  
}

猜你喜欢

转载自blog.csdn.net/qq_40421671/article/details/82791053