卡特兰数(java)

版权声明:莉莉莉 https://blog.csdn.net/qq_41700151/article/details/81354610

卡特兰数java代码
题目

D - Train Problem II
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
Output
For each test case, you should output how many ways that all the trains can get out of the railway.
Sample Input

1
2
3
10

Sample Output

1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.

卡特兰数是一种经典的组合数,经常出现在各种计算中,其前几项为 :
1, 2, 5, 14, 42,
132, 429, 1430, 4862, 16796,
58786, 208012, 742900, 2674440, 9694845,
35357670, 129644790, 477638700, 1767263190,
6564120420, 24466267020, 91482563640, 343059613650, 1289904147324,
4861946401452, …

import java.math.*;
import java.util.*;
public class Main {
    public static void main(String[] args)
    {
        int n;
        Scanner cin = new Scanner(System.in);   
        BigInteger[][]a=new BigInteger [110][110];   
        for(int i=0;i<101;i++)
            for(int j=0;j<101;j++)
                a[i][j]=BigInteger.valueOf(0);
        for(int i=1;i<101;i++)
            a[i][0]=BigInteger.valueOf(1);
        for(int i=1;i<101;i++)
            for(int j=1;j<=i;j++)
            {
                a[i][j]=a[i][j].add(a[i-1][j]);
                a[i][j]=a[i][j].add(a[i][j-1]);
            }
        while(cin.hasNext())   //多组输入
        {
            n=cin.nextInt();
            BigInteger ans=BigInteger.ONE;  //给ans赋初值为1
            //等于BigInteger ans=new BigInteger("1");
            ans=a[n][n];
            System.out.println(ans);   //换行输出
        }
        cin.close();

    }
}

猜你喜欢

转载自blog.csdn.net/qq_41700151/article/details/81354610