hdu 6441Find Integer(CCPC网络赛D 数论+勾股数+费马定理)

目录

题目:

题意:

思路:

AC代码:


题目:

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 117    Accepted Submission(s): 49
Special Judge

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);
else print two integers -1 -1 instead.

Sample Input

1

2 3

Sample Output

4 5

题意:

给出a^{n}+b^{n}=c^{n}中的a,n求b,c的任一组解,不存在输出-1 -1

思路:

通过费马定理可以得出n>2和n=0时,是无解的,然后n=2通过对奇偶性的讨论,我们可以很轻易的得出b和c的一组解。满足

b=a\&1?\frac{(a-1)^{2}}{2}+a-1:\frac{a^{2}}{4}-1,c=a\&1?\frac{(a-1)^{2}}{2}+a:\frac{a^{2}}{4}+1;

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll a,b,c,d,n;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%lld%lld",&n,&a);
        if(n > 2) printf("-1 -1\n");
        else if(n == 0) printf("-1 -1\n");
        else if(n == 1) printf("1 %lld\n",a + 1);
        else if(n == 2){
            b = a & 1 ? (a - 1) * (a - 1) / 2 + a - 1 : a * a / 4 - 1;
            c = a & 1 ? (a - 1) * (a - 1) / 2 + a : a * a / 4 + 1;
            printf("%lld %lld\n",b,c);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41791981/article/details/82054261