HDU-6441-Find Integer(费马大定理+勾股数)ʕ •ᴥ•ʔ

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

扫描二维码关注公众号,回复: 3078829 查看本文章

Sample Input

 

1 2 3

Sample Output

 

4 5

题目大意:给出T组测试样例,对于每组测试数据,输入n,a,输出满足a^n+b^n=c^n的b和c,如果没有满足要求的,输出-1 -1;

费马大定理证明了n>2的时候没有整数满足a^n+b^n==c^n;

当n==1时,任意a,1,a+1即可;

当n==2时,即为勾股数,百度百科有证明过程,分为奇数和偶数,然后根据式子直接输出结果即可:

当a为大于1的奇数2n+1时,b=2n^2+2n, c=2n^2+2n+1

当a为大于4的偶数2n时,b=n^2-1, c=n^2+1

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
//#include <map>
#define ll long long
using namespace std;
#define pai acos(-1,0)
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		ll n,a;
		ll b,c;
		scanf("%lld %lld",&n,&a);
		if(n>2)
		printf("-1 -1\n");
		if(n==1) 
		printf("1 %lld\n",a+1);
		if(n==2)
		{
			if(a%2)
			{
				b=(a-1)*(a-1)/2+a-1;
				c=b+1;
			}
			else
			{
				b=a*a/4-1;
				c=b+2;
			}
			printf("%lld %lld\n",b,c); 
		}
		
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/82191839