HDU-6441-Find Integer(费马大定理+勾股数)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6441

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

 

Input

one line contains one integer T ;(1≤T≤1000000)

next T lines contains two integers n ,a ;(0≤n≤1000 ,000 ,000,3≤a≤40000)

 

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000 ,000 ,000) ;

else print two integers -1 -1 instead.

 

Sample Input

 

1 2 3

 

Sample Output

 

4 5

题目大意:给出T组测试样例,对于每组测试数据,输入n,a,输出满足a^n+b^n=c^n的b和c,如果没有满足要求的,输出-1 -1;

费马大定理证明了n>2的时候没有整数满足a^n+b^n==c^n;

当n==1时,任意a,1,a+1即可;

当n==2时,即为勾股数,百度百科有证明过程,分为奇数和偶数,然后直接输出结果即可:

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<fstream>
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
//#define mod 1e9+7
//#define max(a,b) (a)>(b)?(a):(b)
//#define min(a,b) (a)<(b)?(a):(b) 
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
//std::ios::sync_with_stdio(false);

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		ll n,a;
		scanf("%lld%lld",&n,&a);
		if(n==0||n>2)//费马大定理证明
			printf("-1 -1\n");
		else if(n==1)
			printf("1 %lld\n",a+1);
		else
		{
			ll b,c;
			if(a%2)//a为奇数 
			{
				
				b=(a-1)*(a-1)/2+a-1;
				c=b+1;
			}
			else
			{
				b=a*a/4-1;
				c=b+2;
			}
			if(a*a+b*b==c*c)
				printf("%lld %lld\n",b,c);
			else
				printf("-1 -1\n");
		}
	}
	
}

猜你喜欢

转载自blog.csdn.net/qq_40482358/article/details/82110116
今日推荐