Find Integer(费马大定理+勾股数)

版权声明:本文为博主原创文章,转载请说明出处。 https://blog.csdn.net/xianpingping/article/details/82082665

Find Integer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1029    Accepted Submission(s): 251
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

 

1 2 3

Sample Output

 

4 5

Source

2018中国大学生程序设计竞赛 - 网络选拔赛

Recommend

chendu   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

Statistic | Submit | Discuss | Note

思路:

费马大定理+勾股数

费马大定理:

当整数n>2时,关于x,y,z的方程

没有正整数解。

勾股数:

 ///n为奇数有勾股数(2*n+1,2*n*n+2*n,2*n*n+2*n+1);n为偶数有勾股数(2*n,n*n-1,n*n+1)。

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,n,a,b,c;
    scanf("%d",&t);
    while(t--){
        int flag=0;
        scanf("%d%d",&n,&a);
        if(n>2 || n==0)
        {
            printf("-1 -1\n");
            continue;
        }
        if(n==1)
        {
            b=1;c=a+b;
        }
        else{
         ///n为奇数有勾股数(2*n+1,2*n*n+2*n,2*n*n+2*n+1);n为偶数有勾股数(2*n,n*n-1,n*n+1)。
            if(a%2==1){
                int lala=(a-1)/2;
                b=2*lala*lala+2*lala;
                c=2*lala*lala+2*lala+1;
            }
            else{
                int lala=a/2;
                b=lala*lala-1;
                c=lala*lala+1;
            }
        }
        printf("%d %d\n",b,c);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/82082665