Find Integer HDU - 6441(费马大定理+勾股数)

Find Integer HDU - 6441

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that a n + b n = c n
.
Input
one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000)
;

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5

题意:

给定 n , a b c a n + b n = c n

无解输出-1 -1

分析:

观察可得n=0的时候无解

根据费马大定理可知 n 3 时无解

因此只需要考虑n=2的情况,即勾股数

这里有一个结论:

对于大于2的任意偶数2n(n>1),都可构成一组勾股数,三边分别是:

2 n n 2 1 n 2 + 1

任意一个大于1的奇数2n+1(n>1)为边也可以构成勾股数,其三边分别是:

2 n + 1 2 n 2 + 2 n 2 n 2 + 2 n + 1

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        ll n,a;
        scanf("%lld%lld",&n,&a);
        if(n >= 3 || n == 0)
            printf("-1 -1\n");
        else if(n == 1)
            printf("%lld %lld\n",a,a*2);
        else{
            ll tmp;
            if(a & 1){
                tmp = (a - 1) / 2;
                printf("%lld %lld\n",tmp*tmp*2+tmp*2,tmp*tmp*2+tmp*2+1);
            }
            else{
                tmp = a / 2;
                printf("%lld %lld\n",tmp*tmp-1,tmp*tmp+1);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/82109354