POJ 2262 Goldbach’s Conjecture(哥德巴赫猜想)

n 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach’s conjecture for all even numbers less than a million.
Input
The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.
Output
For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying “Goldbach’s conjecture is wrong.”
Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题意描述:
任意给出一个n这个n大于6,小于1000000,问是否存在两个素数相加等于n,如果有输出,输出的形式是8 = 3 + 5这样的。
AC代码:

#include<stdio.h>
#include<math.h>

int prime(int m)
{
	int i,k;
	double m1;
	m1=m;
	if(m==1)
		return 0;
	k=sqrt(m1);
	for(i=2;i<=k;i++)
		if(m%i==0)
			return 0;
	return 1;
 } 

int main(void)
{
	int i,n;
	while(~scanf("%d",&n))
	{
		int flag=1;
		if(n==0)
			break;
		for(i=2;i<=n/2;i++)
			if(prime(i)==1)
			{
				if(prime(n-i)==1)
				{
				 
					flag=1;
					break;
				} 
			}
		if(flag==1)
			printf("%d = %d + %d\n",n,i,n-i);
		else
			printf("Goldbach's conjecture is wrong.\n");
	}
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1367

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/98356119
今日推荐