中国大学MOOC-陈越、何钦铭-数据结构-2018秋 02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int maxn=1e6+5;
int st,n,re;
struct List
{
    int data;
    int next;
};
int LL[maxn],num=0;
List L[maxn];
int main()
{
    scanf("%d%d%d",&st,&n,&re);
    for (int i=0;i<n;i++)
    {
        int ad,data,next;
        scanf("%d%d%d",&ad,&data,&next);
        L[ad].next=next;
        L[ad].data=data;
    }
    while (st!=-1)
    {
        LL[num++]=st;
        st=L[st].next;
    }
    for (int i=0;i+re<=num;i+=re)
    {
        reverse (LL+i,LL+i+re);
    }
    for (int i=0;i<num-1;i++)
        printf("%05d %d %05d\n",LL[i],L[LL[i]].data,LL[i+1]);
    printf("%05d %d -1\n",LL[num-1],L[LL[num-1]].data);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/82743708
今日推荐