hdu1068

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set. 

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1, for n subjects. 
For each given data set, the program should write to standard output a line containing the result. 

Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Output

5
2

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define maxn 505
using namespace std;

struct ma
{int n;
vector<int>g[maxn];
bool vis[maxn];
int lef[maxn];

void init(int n)
{this->n=n;
    for(int i=0;i<n;i++)
        g[i].clear();
    for(int i=0;i<=maxn;i++)
        lef[i]=-1;
}
bool match(int u)
{
    for(int i=0;i<g[u].size();i++)
    {
        int v=g[u][i];
        if(!vis[v])
        {
            vis[v]=true;
            if(lef[v]==-1||match(lef[v]))
            {
                lef[v]=u;
                return true;
            }
        }
    }
        return false;

}
int solve()
{
    int ans=0;
    for(int i=0;i<n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(match(i))
            ans++;
    }
    return ans;
}
}MM;
int main()
{int n;
    while(~scanf("%d",&n))
    {MM.init(n);
        for(int i=0;i<n;i++)
        {int u,k;
            scanf("%d: (%d)",&u,&k);
            while(k--)
            {
                int v;
                scanf("%d",&v);
                MM.g[u].push_back(v);
            }
        }

       printf("%d\n",n-MM.solve()/2);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88539680
今日推荐