hdu 1022 Train Problem I (栈)

转载来源:https://blog.csdn.net/lyhvoyage/article/details/18505997

题目描述:

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321

3 123 312

Sample Output

Yes.

in

in

in

out

out

out

FINISH

No.

FINISH

For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".

这里主要是通过栈来实现。但是自己只知道是用栈,但写不出代码

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<stack>
using namespace std;
int main()
{
    int T, flag[10];
    char s1[10], s2[10];
    while(scanf("%d%s%s",&T,s1,s2)!=EOF)
    {
        stack<char>S;
        //这里j和k都用的特别好
        //j通过与i的关系主要是用来比较两个字符串相同位置数字是否相同
        //k主要是用来统计进出栈的总操作次数,然后根据这个数字来输出in和out
        int j=0;
        int k=0;//k表进出栈的次数
        for(int i=0;i<T;i++)
        {
           S.push(s1[i]);
           flag[k++]=1;//表进栈
           while(!S.empty()&&S.top() == s2[j])
               //S.top==s2[j]主要是用来判断栈顶位置的元素与s2数组中的值是否相同,通过j++改变比较的位置
            {
                flag[k++]=0;//表出栈
                S.pop();//数值出
                j++;//出栈的个数
            }
        }

        if(j == T)//符合全部出栈
        {
            printf("Yes.\n");
            for( int i = 0; i < k; i++)
            {
                if(flag[i])
                    printf("in\n");
                else
                    printf("out\n");
            }
        }
        else
            printf("No.\n");

		printf("FINISH\n");
    }
    return 0;
}




猜你喜欢

转载自blog.csdn.net/fanxingxue/article/details/82390692