STL——Train Problem I

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


        
  
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
res
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".

后输入的先输出,明显利用栈解决,我这里设置了一个result数组来保存火车行驶的状态,利用两个循环把输入数据入栈出栈,如果在结束之后栈为空,说明火车已经全部成功驶出,否则即输出No

hdu1022 http://acm.hdu.edu.cn/showproblem.php?pid=1022

#include <iostream>
#include <string.h>
#include <stack>
using namespace std;

int main()
{
    char s1[15],s2[15];
    int res[25];
    int n;
    while(cin>>n>>s1>>s2){
        int k=0;
        int j=0;
        stack<char>a;
        for(int i=0;i<n;i++){
            a.push(s1[i]);
            res[k++]=1;
            while(!a.empty()&&a.top()==s2[j]){
                res[k++]=0;
                a.pop();
                j++;
            }
        }
        if(a.empty()){
            cout<<"Yes."<<endl;
            for(int i=0;i<k;i++){
                if(res[i]==1)
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
            }
            cout<<"FINISH"<<endl;
        }
        else{
            cout<<"No."<<endl;
            cout<<"FINISH"<<endl;
        }
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/suqia/article/details/81081752