Train Problem I ————栈和队列

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
这里写图片描述 这里写图片描述 这里写图片描述

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.


给你进站火车的编号,问你进站的火车能不能以第二种形式出来,

思路:用栈来模拟这个过程


#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<iostream> 
#include<vector>
#include<stack>
#include<algorithm>
using namespace std;

int main()
{
    ios::sync_with_stdio(0);
    int n;
    string s1,s2;
    while(cin>>n>>s1>>s2)
    {
        int a[100];
        int b[100];
        int c[10000];
        stack<int> s;
        for(int i=0;i<s1.size();i++)
            a[i]=s1[i]-'0';
        for(int i=0;i<s2.size();i++)
            b[i]=s2[i]-'0';
        int j=0;
        int k=0;
        int z=0;
        while(j<n&&k<n)
        {
            s.push(a[j++]);
            c[z++]=1;
            while(s.top()==b[k]&&k<n)
//          while(s.top()==b[k])
            {
                k++;
                s.pop();
                c[z++]=0;
                if(s.size()==0) break;
            }
        }
        if(j==n&&k==n)
        {
            printf("Yes.\n");
            for(int i=0;i<z;i++)
                if(c[i])    printf("in\n");
                else        printf("out\n");
        }       
        else
            printf("No.\n");        
        printf("FINISH\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hpuer_random/article/details/81268175
今日推荐