HDU-Train Problem I

Train Problem I


As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

Sample Input
 
  
3 123 321 3 123 312
Sample Output
 
   
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

 题意:给出一个进栈顺序,给出一个出栈顺序,判断是否此出栈顺序是否可能,若可能则输出是如何进栈出栈的。

显然要用到栈的数据结构。
 思路:先把入栈顺序与出栈顺序保存起来,再建立一个数组来保存出栈入栈信息,比如入栈为0,出栈为1。然后按入栈顺序一次一个元素的入栈,每入栈一个元素按顺序与出栈顺序序列相比较
若相等,则说明该元素进栈后立马出栈,标记出入栈信息数组。若不相等则继续入栈一个元素,知道与出栈顺序的第一个元素相等为止。
代码:
#include<stdio.h>
#include<stack>
#include<malloc.h>
using namespace std;
int main() {
	char ch,*in,*out;
	int *inou;
	int n;
	while (~scanf("%d", &n)) {
		stack<char> s;
		in = (char*)malloc(n * sizeof(char));
		out = (char*)malloc(n * sizeof(char));
		inou = (int*)malloc(2 * n * sizeof(int));
		scanf("%s%s", in, out);
		int i=0,j=0;
		int c = 0;
		s.push(in[0]); inou[c++] = 0;
		while (i < n&&j < n) {
			if (!s.empty() && s.top() == out[j]) {
				s.pop();
				inou[c++] = 1;
				j++;
			}
			else {
				i++;
				if (i == n) break;
				s.push(in[i]);
				inou[c++] = 0;
			}
		}
		if (i!=n)
		{
			printf("Yes.\n");
			for (int i = 0; i < 2 * n; i++)
				printf("%s", inou[i] ? "out\n" : "in\n");
		}
		else 
			printf("No.\n");
		printf("FINISH\n");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Titanium_S/article/details/79198383