hdu oj 1022 Train Problem

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    

Memory Limit: 65536/32768 K (Java/Others)
 

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

 

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

Sample Input

3 123 321 3 123 312

Sample Output

Yes. in in in out out out FINISH No. FINISH

Hint

Hint For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".

 

Author

Ignatius.L

 

Recommend

一个栈的题。。

当前在火车进站的车在下一辆没进站之前是可以出去的。

因此在扫描后面车的编号时, 如果与栈顶元素相同, 它就可能会先出来。

#include <bits/stdc++.h>

using namespace std;

int main(){
    ios::sync_with_stdio(0);
    int n, f, i, j, k;
    char s1[20], s2[20];
    bool v[20];
    while(cin >> n)
    {
        cin >> s1 >> s2;
        stack <char> s;
        memset(v, 0, sizeof(v));
        f = i = j  = k = 0;
        while(j < n){
            if(s1[i] == s2[j]){
                i++;
                j++;
                v[k++] = 1;
                v[k++] = 0;
            }
            else if(!s.empty() && s.top() == s2[j]){
                s.pop();
                j++;
                v[k++] = 0;
            }
            else if(i < n){
                v[k++] = 1;
                s.push(s1[i++]);
            }
            else{
                f = 1;
                break;
            }
        }
        if(!f)  cout << "Yes." << endl;
        else   cout << "No."  << endl;
        if(!f){
            for(i = 0; i < k; i++){
                if(v[i])  cout << "in" << endl;
                else   cout << "out" << endl;
            }
        }
        cout << "FINISH" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zx__zh/article/details/82118511
今日推荐