HDU-1022(Train Problem I)

题目

Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

题目大意

有一个和栈一样的火车站;
输入数据有多组,n(火车数),o1(进车站时的火车顺序),o2(出车站时的火车顺序)
需要求是否能将火车以o2的顺序出火车站是的话输出Yes并输出进出顺序否则输出No;
每个样例后输出FINISH

AC代码

#include<cstdio>
#include<stack>
using namespace std;
int main()
{
    char a[15],b[15];
    int c[20];
    int n;
    int a1,b1,c1;
    stack<int> ss;
    while(~scanf("%d %s %s",&n,a,b))
    {
        a1=0;
        b1=0;
        c1=0;
        while(1)
        {
            if(a1>=n&&(b1>=n||(ss.top()!=b[b1])))
                break;
            if(ss.empty())
            {
                if(a1<n)
                {
                    ss.push(a[a1++]);
                    c[c1++]=1;
                }
            }
            else if(!ss.empty())
            {
                if(ss.top()==b[b1])
                {
                    ss.pop();
                    b1++;
                    c[c1++]=2;
                }
                else if(a1<n)
                {
                    ss.push(a[a1++]);
                    c[c1++]=1;
                }
            }
        }
        if(ss.empty())
        {
            printf("Yes.\n");
            for(int i=0; i<c1; i++)
                if(c[i]==1)
                    printf("in\n");
                else
                    printf("out\n");
        }
        else
            printf("No.\n");
        printf("FINISH\n");
        while(!ss.empty())
            ss.pop();
    }
}

猜你喜欢

转载自blog.csdn.net/qq_43984169/article/details/87520471