Train Problem I(栈的应用)

题目出处(点击)
Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
在这里插入图片描述
在这里插入图片描述在这里插入图片描述
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.
题意:
就是给定一个进栈顺序,再给出一个出栈顺序,然后判断是否正确的出栈顺序。
思路:
直接给代码加注释

#include <iostream>
#include <cstring>
#include <stack>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
string in,out;	//输入输出队列
string order[100];	//输出消息 
void trainStation(int n)
{
	stack<char> s;
	cin >> in >> out;
	int j = 0,k = 0;
	for(int i = 0;i < n; i++)
	{
		s.push(in[i]);	//进栈的过程
		order[k++] = "in";
		while(!s.empty() && s.top() == out[j])	//判断此时它是否出去,如果出去,是否栈中有其他元素,还没出去,
		{
			s.pop();	//出栈
			order[k++] = "out";		//出栈的过程
			j++; 
		}
	} 
	if(s.empty())		//如果栈空的说明是正确的
	{
		cout << "Yes." << endl;
		for(int i = 0; i < k; i++)
		{
			cout << order[i] << endl;
		}
		cout << "FINISH" << endl;
	}
	else		//否者,不正确
		cout << "No." << endl << "FINISH" << endl;
}

int main()
{
	int n;
	string st1,st2;
	while(scanf("%d",&n)!=EOF)
	{
		trainStation(n);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_46687179/article/details/105623739