【HDU 1104】Remainder (BFS+数论)

Remainder
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4720 Accepted Submission(s): 1192

Problem Description
Coco is a clever boy, who is good at mathematics. However, he is puzzled by a difficult mathematics problem. The problem is: Given three integers N, K and M, N may adds (‘+’) M, subtract (‘-‘) M, multiples (‘*’) M or modulus (‘%’) M (The definition of ‘%’ is given below), and the result will be restored in N. Continue the process above, can you make a situation that “[(the initial value of N) + 1] % K” is equal to “(the current value of N) % K”? If you can, find the minimum steps and what you should do in each step. Please help poor Coco to solve this problem.

You should know that if a = b * q + r (q > 0 and 0 <= r < q), then we have a % q = r.

Input
There are multiple cases. Each case contains three integers N, K and M (-1000 <= N <= 1000, 1 < K <= 1000, 0 < M <= 1000) in a single line.

The input is terminated with three 0s. This test case is not to be processed.

Output
For each case, if there is no solution, just print 0. Otherwise, on the first line of the output print the minimum number of steps to make “[(the initial value of N) + 1] % K” is equal to “(the final value of N) % K”. The second line print the operations to do in each step, which consist of ‘+’, ‘-‘, ‘’ and ‘%’. If there are more than one solution, print the minimum one. (Here we define ‘+’ < ‘-‘ < ‘’ < ‘%’. And if A = a1a2…ak and B = b1b2…bk are both solutions, we say A < B, if and only if there exists a P such that for i = 1, …, P-1, ai = bi, and for i = P, ai < bi)

Sample Input

2 2 2
-1 12 10
0 0 0

Sample Output

0
2
*+

Author
Wang Yijie
调了两个多小时的BUG,居然是变量名输反了,一定要仔细看题啊。
一般如果给了你状态并让你求最小的步数这类的题,不出意外应该
是BFS,在这里我们要说一下mod和%的区别,%可正可负,而mod只可能
是正数。那么我们有这样一个式子: a m o d b = ( a % b + b ) % b
在四种变化中, + , , 对mod没有影响,但是在% m 之后如果再% k
答案就会错误。那么我们这时候就要% ( m k ) (m和k的公倍数)。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 3000000;
typedef long long ll;
struct node{
    ll step;
    ll num;
    string ans;
};
bool vis[maxn];
ll n,m,k;
void bfs(){
    memset(vis,0,sizeof(vis));
    queue<node> q;
    node nt;
    nt.num=n;
    nt.ans="";
    nt.step=0;
    vis[(n%k+k)%k]=1;
    q.push(nt);
    while(!q.empty()){
        node rt=q.front();
        q.pop();
        if((rt.num%k+k)%k==((n+1)%k+k)%k){
            printf("%lld\n",rt.step);
            cout<<rt.ans<<endl;
            return ;
        }
        nt.step=rt.step+1;
        for(int i=0;i<4;i++){
            if(i==0){
                nt.num=(rt.num+m)%(m*k);
                nt.ans=rt.ans+'+';
            }
            else if(i==1){
                nt.num=((rt.num)-m)%(m*k);
                nt.ans=rt.ans+'-';
            }
            if(i==2){
                nt.num=(rt.num*m)%(m*k);
                nt.ans=rt.ans+'*';
            }
            if(i==3){
                nt.num=(rt.num%m+m)%m%(m*k);
                nt.ans=rt.ans+'%';
            }
            if(!vis[(nt.num%k+k)%k]){
                vis[(nt.num%k+k)%k]=1;
                q.push(nt);
            }
        }
    }
    puts("0");
}
int main(){
    while(scanf("%lld %lld %lld",&n,&k,&m)){
        if(n==0&&m==0&&k==0) return 0;
        bfs();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/duanghaha/article/details/82378106