HDU 1372 Knight Moves 【BFS+特殊例子】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1372

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 

InputThe input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
OutputFor each test case, print one line saying "To get from xx to yy takes n knight moves.". 
Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

思路:类似国际象棋,给定一个矩阵,Knight(骑士)有8个方向可走,相当于象棋中的马走日,引入8个方向的方向数组,按照要求输出,用优先队列,剪枝也得正确。代码如下:

#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
using namespace std;
int vis[10][10];
int map[10][10];
struct node{
	int x;
	int y;
	int step;
	bool friend operator < (node a,node b)
	{
		return a.step>b.step;
	}
};
int dir[8][2]={-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,-2,-2,-1};
int BFS(int a,int b) {
	memset(vis,0,sizeof(vis));
	priority_queue<node>que;
	node e1,e2;
	e1.x=a,e1.y=b,e1.step=0;
	vis[a][b]=1;
	que.push(e1);
	int ans=-1;
	while(!que.empty()){
		e2=que.top();
		que.pop();
		if(map[e2.x][e2.y]==2)
		{
			ans=e2.step;
			break;
		}
		for(int i=0;i<8;i++)
		{
			e1.x=e2.x+dir[i][0];
			e1.y=e2.y+dir[i][1];
		
			if(e1.x>=1&&e1.x<=8&&e2.y>=1&&e2.y<=8&&!vis[e1.x][e1.y]) //剪枝
			{
			  e1.step=e2.step+1;
			  vis[e1.x][e1.y]=1;
			  que.push(e1);	
			}
		}
		
	}
	return ans;
}

int main()
{
	char a1[3],b1[3];
	int c;
	while(cin>>a1>>b1)
	{
		memset(map,0,sizeof(map));
		map[a1[0]-'a'+1][a1[1]-'0']=1;
		map[b1[0]-'a'+1][b1[1]-'0']=2;
		c=BFS(a1[0]-'a'+1,a1[1]-'0');
		printf("To get from %s to %s takes %d knight moves.\n",a1,b1,c);
	}
	return 0;
}

ps:我们都有类似的遗憾!

猜你喜欢

转载自blog.csdn.net/LOOKQAQ/article/details/81349303