UVA - 1594——Ducci Sequence【vector,set】

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, · · · , an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

(a1, a2, · · · , an) → (|a1 − a2|, |a2 − a3|, · · · , |an − a1|)

  Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8, 11, 2, 7) → (3, 9, 5, 1) → (6, 4, 4, 2) → (2, 0, 2, 4) → (2, 2, 2, 2) → (0, 0, 0, 0).

  The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4, 2, 0, 2, 0) → (2, 2, 2, 2, 4) → (0,0,0,2,2) → (0, 0, 2, 0, 2) → (0, 2, 2, 2, 2) → (2, 0, 0, 0, 2) →(2, 0, 0, 2, 0) → (2, 0, 2, 2, 2) → (2, 2, 0, 0, 0) → (0, 2, 0, 0, 2) → (2, 2, 0, 2, 2) → (0, 2, 2, 0, 0) →(2, 0, 2, 0, 0) → (2, 2, 2, 0, 2) → (0, 0, 2, 2, 0) → (0, 2, 0, 2, 0) → (2, 2, 2, 2, 0) → (0,0,0,2,2) → · · ·

  Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4

4

8 11 2 7

5

4 2 0 2 0

7

0 0 0 0 0 0 0

6

1 2 3 1 2 3

Sample Output

ZERO

LOOP

ZERO

LOOP

题目大意:给你一个数组,可以对于每个书求出它和下一个数的差的绝对值,得到一个新的数组。重复这个过程,得到的欲裂成为Ducci序列。判断他最终会变成0还是会循环。

思路:每进行一次上述操作就把该数组存入一个set中,然后判断是否出现循环或者全部为0.

#include <bits/stdc++.h>
using namespace std;

vector<int> v,zero;
set< vector<int> > se;

int main(int argc, char const *argv[])
{
	int t, n;
	scanf("%d",&t);
	while(t--){
		v.clear();
		zero.clear();
		se.clear();
		scanf("%d",&n);
		int temp;
		for(int i = 0; i < n; i++){
			scanf("%d",&temp);
			v.push_back(temp);
			zero.push_back(0);
		}
		se.insert(v);
		for(; ;){
			if(v == zero){
				puts("ZERO");
				break;
			}
			else{
				int a = abs(v[0] - v[1]);
				for(int i = 1; i < n; i++){
					v[i] = abs(v[i] - v[(i + 1) % n]);
				}
				v[0] = a;
				if(se.count(v)){
					puts("LOOP");
					break;
				}
				else{
					se.insert(v);
				}
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/82432354