UVA 1594 vector的集合与相等运算符

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, · · · , an),
the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:
(a1, a2, · · · , an) → (|a1 − a2|, |a2 − a3|, · · · , |an − a1|)
Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple
sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:
(8, 11, 2, 7) → (3, 9, 5, 1) → (6, 4, 4, 2) → (2, 0, 2, 4) → (2, 2, 2, 2) → (0, 0, 0, 0).
The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:
(4, 2, 0, 2, 0) → (2, 2, 2, 2, 4) → (0,0,0,2,2) → (0, 0, 2, 0, 2) → (0, 2, 2, 2, 2) → (2, 0, 0, 0, 2) →
(2, 0, 0, 2, 0) → (2, 0, 2, 2, 2) → (2, 2, 0, 0, 0) → (0, 2, 0, 0, 2) → (2, 2, 0, 2, 2) → (0, 2, 2, 0, 0) →
(2, 0, 2, 0, 0) → (2, 2, 2, 0, 2) → (0, 0, 2, 2, 0) → (0, 2, 0, 2, 0) → (2, 2, 2, 2, 0) → (0,0,0,2,2) → · · ·
Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple
or a periodic loop.
Input
Your program is to read the input from standard input. The input consists of T test cases. The number
of test cases T is given in the first line of the input. Each test case starts with a line containing an
integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following
line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to
1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple
or making a loop does not exceed 1,000.
Output
Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if
the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.
Sample Input
4
4
8 11 2 7
5
4 2 0 2 0
7
0 0 0 0 0 0 0
6
1 2 3 1 2 3
Sample Output
ZERO
LOOP
ZERO
LOOP

vector重载了相等运算符,所以判断2个序列相等只需要把零序列resize到相同的大小,然后直接用==即可判断是否ZERO

判断LOOP则需要使用set<vector<int> >

#include<bits/stdc++.h>
using namespace std;

int main() {
    //freopen("datain.txt","r",stdin);
    int T;
    vector<int> seq,zeroSeq;
    set<vector<int> >seqs; //用集合来判重
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        seqs.clear();
        zeroSeq.resize(n);
        seq.clear();
        int t;
        for(int i=0;i<n;i++){
            scanf("%d",&t);
            seq.push_back(t);
        }
        seqs.insert(seq);
        for(;;){
            int first=seq[0];
            for(int i=0;i<n-1;i++){
                seq[i]=abs(seq[i]-seq[i+1]);
            }
            seq[n-1]=abs(seq[n-1]-first);
            if(seq==zeroSeq){
                puts("ZERO");
                break;
            }
            if(seqs.count(seq)){
                puts("LOOP");
                break;
            }
            seqs.insert(seq);
        }
    }
}

猜你喜欢

转载自blog.csdn.net/hanker99/article/details/88317993
今日推荐