UVA 1584 Circular Sequence

UVA 1584 Circular Sequence

紫书第三章例题的最后一个,题解用了指针,不过我更喜欢用全局变量

Some DNA sequences exist in circular forms as in
the following figure, which shows a circular sequence
“CGAGTCAGCT”, that is, the last symbol “T” in
“CGAGTCAGCT” is connected to the first symbol “C”. We always
read a circular sequence in the clockwise direction.
Since it is not easy to store a circular sequence in a computer
as it is, we decided to store it as a linear sequence.
However, there can be many linear sequences that are obtained
from a circular sequence by cutting any place of the
circular sequence. Hence, we also decided to store the linear
sequence that is lexicographically smallest among all linear
sequences that can be obtained from a circular sequence.
Your task is to find the lexicographically smallest sequence
from a given circular sequence. For the example in the figure,
the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that
are lexicographically smallest, you are to find any one of them (in fact, they are the same).
Input
The input consists of T test cases. The number of test cases T is given on the first line of the input
file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear
sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are
allowed. Each sequence has length at least 2 and at most 100.
Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence
for the test case.
Sample Input
2
CGAGTCAGCT
CTCC
Sample Output
AGCTCGAGTC
CCCT

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<string.h>
#define maxn 105
#define ll long long
#define INF 0x3f3f3f3f3f3f3f3f
using namespace std;
char s[maxn];
int len;
int number(int x,int y){
    char s1,s2;
    int i;
    for(i=0;i<len;i++){
        s1=s[(x+i)%len];
        s2=s[(y+i)%len];
        if(s1<s2)
        return 1;
        if(s1>s2)
        return 0;
    }
    return 0;
}
int main()
{
//  freopen("input.txt","r",stdin);
//  freopen("output.txt","w",stdout);
    int t,i,k;
    scanf("%d",&t);
    while(t--){
        scanf("%s",s);
        len=strlen(s);
        k=0;
        for(i=0;i<len;i++){
            if(number(i,k)){
                k=i;
            }
        }
        for(i=0;i<len;i++){
            printf("%c",s[(i+k)%len]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/mandiheyanyu/article/details/82285101
今日推荐