Ducci序列(Ducci Sequence ,UVa1594)

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1,a2,···,an), the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:

(a1,a2,···,an) → (|a1 − a2|,|a2 − a3|,···,|an a1|)

Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:

(8,11,2,7) → (3,9,5,1) → (6,4,4,2) → (2,0,2,4) → (2,2,2,2) → (0,0,0,0).

The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:

(4,2,0,2,0) → (2,2,2,2,4) → (0,0,0,2,2) → (0,0,2,0,2) → (0,2,2,2,2) → (2,0,0,0,2) →

(2,0,0,2,0) → (2,0,2,2,2) → (2,2,0,0,0) → (0,2,0,0,2) → (2,2,0,2,2) → (0,2,2,0,0) →

(2,0,2,0,0) → (2,2,2,0,2) → (0,0,2,2,0) → (0,2,0,2,0) → (2,2,2,2,0) → (0,0,0,2,2) → ···

Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing an integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to 1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4

4

8 11 2 7

5

4 2 0 2 0

7

0 0 0 0 0 0 0

6

1 2 3 1 2 3

Sample Output

ZERO

LOOP

ZERO

LOOP

 题意如下:

1、有一个由n个元组(a1,a2,a3,......,an)组成的数组,可以对于每个数求出它和下个数的差的绝对值,得到一个新的由n个元组组成的数组(|a1-a2|,|a2-a3|,...,|an-a1|)。重复这个过程,得到的序列称为Ducci序列。

2、Ducci序列有的最终会循环,也有的最终会变成0。

3、输入保证最多1000步就会变成1000步或者循环。

代码如下:


#include <cstdio>
#include <cstring>
#include <queue>
#include <iostream>
#include <cmath> 
#include <cstdlib>
using namespace std;
int s[1005][16];//创建一个二维数组。 
bool k=true; 
int main()
{
   int T;	
   cin>>T;
   while(T--)
   {
   		int n;
  		cin>>n;
		k=true;   
   		for(int i=0;i<n;i++)//把数输入数组中 
   			cin>>s[0][i];
   		for(int i=1;i<1001;i++)//1000步循环 
   		{	
			for(int j=0;j<n;j++)//对每个数求出它和下个数的差的绝对值,得到新数组 
				{
					if(j==n-1)
					s[i][j]=abs(s[i-1][j]-s[i-1][0]);
					else
					s[i][j]=abs(s[i-1][j]-s[i-1][j+1]);
				}
		}
	
		for(int i=0;i<n;i++)
		{
			if(s[1000][i]!=0)//判断是否循环。 
			{
				k=false;
			}
		}
		if(k==true)
		cout<<"ZERO"<<endl;
		else
		cout<<"LOOP"<<endl;
	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Genius_panda_ACM/article/details/81211104
今日推荐