习题5-2 Ducci序列(Ducci Sequence, ACM/ICPC Seoul 2009, UVa1594)C语言编写

题目描述:
对于一个n元组(a1, a2, … , an),可以对于每个数求出它和下一个数的差的绝对值,得到一个新的 n 元组 (|a1-a2|, |a2-a3|, … , |an-a1|)。重复这个过程,得到的序列称之为 Ducci 序列。求Ducci数列如果在1000步以内循环了,就输出 LOOP,否则输出 ZERO

A Ducci sequence is a sequence of n-tuples of integers. Given an n-tuple of integers (a1, a2, · · · , an),the next n-tuple in the sequence is formed by taking the absolute differences of neighboring integers:
(a1, a2, · · · , an) → (|a1 − a2|, |a2 − a3|, · · · , |an − a1|)
Ducci sequences either reach a tuple of zeros or fall into a periodic loop. For example, the 4-tuple sequence starting with 8,11,2,7 takes 5 steps to reach the zeros tuple:
(8, 11, 2, 7) → (3, 9, 5, 1) → (6, 4, 4, 2) → (2, 0, 2, 4) → (2, 2, 2, 2) → (0, 0, 0, 0).
The 5-tuple sequence starting with 4,2,0,2,0 enters a loop after 2 steps:
(4, 2, 0, 2, 0) → (2, 2, 2, 2, 4) → (0,0,0,2,2) → (0, 0, 2, 0, 2) → (0, 2, 2, 2, 2) → (2, 0, 0, 0, 2) →
(2, 0, 0, 2, 0) → (2, 0, 2, 2, 2) → (2, 2, 0, 0, 0) → (0, 2, 0, 0, 2) → (2, 2, 0, 2, 2) → (0, 2, 2, 0, 0) →
(2, 0, 2, 0, 0) → (2, 2, 2, 0, 2) → (0, 0, 2, 2, 0) → (0, 2, 0, 2, 0) → (2, 2, 2, 2, 0) → (0,0,0,2,2) → · · ·
Given an n-tuple of integers, write a program to decide if the sequence is reaching to a zeros tuple
or a periodic loop.

Input

Your program is to read the input from standard input. The input consists of T test cases. The number
of test cases T is given in the first line of the input. Each test case starts with a line containing an
integer n (3 ≤ n ≤ 15), which represents the size of a tuple in the Ducci sequences. In the following
line, n integers are given which represents the n-tuple of integers. The range of integers are from 0 to
1,000. You may assume that the maximum number of steps of a Ducci sequence reaching zeros tuple
or making a loop does not exceed 1,000.

Output

Your program is to write to standard output. Print exactly one line for each test case. Print ‘LOOP’ if
the Ducci sequence falls into a periodic loop, print ‘ZERO’ if the Ducci sequence reaches to a zeros tuple.

Sample Input

4
4
8 11 2 7
5
4 2 0 2 0
7
0 0 0 0 0 0 0
6
1 2 3 1 2 3
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9

Sample Output

ZERO
LOOP
ZERO
LOOP

对于这道题,用数组直接模拟即可

源代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<math.h>
using namespace std;
int num[2000]={0};
int main(){
    int N;
    cin>>N;
    while(N--){
        int a,b,c,d,temp=0,temp1=0;
        cin>>temp;
        temp1 = temp;
        for(int i = 0;i<temp1;i++){
            cin>>num[i];
        }
        int sum = 1000;
        int i =0;
        int t_num = num[0];
        while(sum--){
            for(i = 0;i< temp1-1;i++){
                num[i] = abs(num[i] - num[i+1]);
            }
            num[i] = abs(num[i] - t_num);
            t_num = num[0];
        }
        int flag = 1;
        for(int i = 0;i < temp1;i++){
            if(num[i]!=0)
                flag = 0;
        }
        if(flag)
            cout<<"ZERO"<<endl;
        else
            cout<<"LOOP"<<endl;        
    }
}  

猜你喜欢

转载自blog.csdn.net/m0_49019274/article/details/109037748
今日推荐