Poj3461 Oulipo

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 47526   Accepted: 18919

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

扫描二维码关注公众号,回复: 2166251 查看本文章
1
3
0

Source

这题的题意大概是这样:给出两个串S1,S2(只有大写字母),求S1在S2中出现了多少次。

详情请看样例


思路:一开始看到就立马想到是KMP,但是这里我用了字符串hash,不了解的朋友可先自行学习。

上代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N = 1000005;
const int k = 27;
string s1,s2;
int n,ans,len_s1,len_s2;
unsigned long long power[N],sum[N],s;//usigned long long 哈希神器(自然溢出)
int main()
{
	ios::sync_with_stdio(false);//关闭同步(应该会快一点点(>___<))
	power[0]=1;
	for(int i=1;i<=N-4;i++) power[i]=power[i-1]*k;
 	cin>>n;
 	while(n--){
 		ans=0;
 		cin>>s1>>s2;
 		len_s1=s1.length();
		len_s2=s2.length();
		s1=" "+s1;s2=" "+s2;
 		for(int i=1;i<=len_s2;i++) sum[i]=sum[i-1]*k+s2[i]-'A'+1;//计算S2的hash值
 		s=0;
 		for(int i=1;i<=len_s1;i++) s=s*k+s1[i]-'A'+1;//计算S1的hash值
 		for(int i=len_s1;i<=len_s2;i++) if(sum[i]-sum[i-len_s1]*power[len_s1]==s)  ans++;//匹配
 		cout<<ans<<endl;
	 }
   return 0;
}//还挺短的,嗯。

猜你喜欢

转载自blog.csdn.net/qq_38944163/article/details/80934504
今日推荐