POJ 3461 Oulipo(哈希)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0


题意:给你一个W串和T串,问你W串在T串中出现了多少次

解题思路:字符串hash,同样也是kmp算法的模板

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef unsigned long long ull;//可以自动溢出
const int base=31;//相当于转换成31进制的数
const int maxn=1000050;
char w[maxn],t[maxn];
ull a[maxn],hat[maxn];
int main()
{
    int T;
    scanf("%d",&T);
    a[0]=1;
    for(int i=1;i<maxn;i++)
        a[i]=a[i-1]*base;
    while(T--){
        memset(w,0,sizeof(w));
        memset(t,0,sizeof(t));
        scanf("%s",w);
        scanf("%s",t);
        int lenw=strlen(w);
        int lent=strlen(t);
        ull haw=0;
        for(int i=lenw-1;i>=0;i--){
            haw=haw*base+w[i];//求到字串的hash值
        }
        hat[lent]=0;
        for(int i=lent-1;i>=0;i--){
            hat[i]=hat[i+1]*base+t[i];
        }
        int ans=0;
        for(int i=0;i<=lent-lenw;i++){
            if(haw==hat[i]-hat[i+lenw]*a[lenw])
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44003265/article/details/104037281
今日推荐