【POJ 3461】 Oulipo(KMP)

Oulipo

Time Limit: 1000MS Memory Limit: 65536K

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题目大意:输入T组数据。每组数据两个字符串,你将第一个字符串在第二个字符串中出现的次数输出。如AZA在AZAZA中有2次,在AZAZAZA中有三次。

分析:典型的KMP问题。单模式匹配。
不懂KMP算法的请参考:
http://www.ruanyifeng.com/blog/2013/05/Knuth%E2%80%93Morris%E2%80%93Pratt_algorithm.html

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e4+5;

int next[maxn];

char str1[maxn];
char str2[1000005];

/*/////简单但是会超时 
void MakeNext( char *p ){
    int i,k;//Q记录字符串下标 k是最大前后相同缀长度
    int m = strlen(p);//字符串长度
    next[0] = -1;//第一个字符串的前后缀长度为0
    for( i=1 , k=0 ; i<m ; i++ ){
        while( k>0 && p[i] != p[k] ){
   
   //求出p[0]-->p[i]的最大前后缀长度 
            k = next[k-1];
        } 
        if( p[i] == p[k] ){
            k++;
        }
        next[i] = k;
    } 
} 
*/

void MakeNext( char *str ){
    int n = strlen(str);
    int i = 0, j = -1;
    next[0] = -1;
    while( i < n ){
        if( j == -1 || str[i] == str[j] )
            next[++i] = ++j;
        else
            j = next[j];
    }
}

int kmp( char *p,char *str ){
    int n = strlen(p);
    int m = strlen(str);
    int i = 0;
    int j = 0;
    int cnt = 0;
    while( i<m && j<n ){
        if( str[i] == p[j] || j == -1 ){
            i++;
            j++;
        }
        else{
            j = next[j];
        }
        if( j == n ){
            cnt++;
            j = next[j];
        }
    }
    return cnt;
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s",str1);
        scanf("%s",str2);
        MakeNext( str1 );
        int ans = kmp( str1,str2 );
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/52152465
今日推荐