POJ3320 Jessica's Reading Problem(尺取法+STL预处理)

题目链接https://vjudge.net/problem/POJ-3320

题目如下

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

这道题需要用到尺取法:先向后推进右端点,直到子序列覆盖所有的知识点,然后左端点向右推进,直到刚好没有覆盖所有知识点,然后再推进右端点.....重复这个过程,直到数组末尾

通过笔算一下能够更加理解尺取法

但是这道题需要先用STL的set容器(集合)处理,排除包含的知识点相同的情况

代码如下

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<map>
#include<set>
using namespace std;
int a[1000005];
map<int,int>cnt;
set<int>t;
int main()
{
	int p;
	cin>>p;
	int pl=0,sum=0;
	int minn=0x7f7f7f7f;
	for(int i=0;i<p;i++)
	{
		scanf("%d",&a[i]);
		t.insert(a[i]);
	}
	int total=t.size();
	for(int i=0;i<p;i++)
	{
		if(cnt[a[i]] ++ == 0)sum++;
		if(sum>=total)
		{
			while(sum>=total)
			{
				if(--cnt[a[pl++]]==0)sum--;
			}
			minn=min(minn,i-pl+2);
		}
	}
	cout<<minn<<endl;
	return 0;
}

注意第29行向左推进的方法

猜你喜欢

转载自blog.csdn.net/qq_41626975/article/details/82192767