集训笔记---尺取法(POJ NO.3320 Jessica's Reading Problem)

Jessica's Reading Problem

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16596   Accepted: 5752

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

尺取法的应用,欢迎指正

#include<cstdio>
#include<set>
#include<map>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
const int MAX_N = 100010;
int a[MAX_N];
map<int, int> kd;
int main(void)
{
    int p, i, t, s;
    set<int> sh;
    scanf("%d", &p);
    for(i = 0; i < p; i++)
    {
        scanf("%d", &a[i]);
        sh.insert(a[i]);
    }
    int n = sh.size();
    int sum = 0;
    t = 0;
    s = 0;
    int res = p;
    //利用map存储每一个知识点(不是页码)已获得的数目
    //最重要的用途是用于判定起点S向前翻动时S页上的知识点是否消失
    while(1)
    {
        while((t < p) && (sum < n))
        {
            if(kd[a[t]] == 0)//如果T页上的知识点从未被获取过,那么sum++;
            {
                sum++;
            }
            kd[a[t]]++;//相应知识点增加
            t++;//模拟翻页这个动作
        }
        if(sum < n)//循环终止条件
        {
            break;
        }
        res = min(res, t-s);//寻求最优解
        if(kd[a[s]] == 1)//如果S页上的知识点只有一个,那么毛毛虫向前移位将造成sum--
        {
            sum--;
        }
        kd[a[s]]--;
        s++;
    }
    printf("%d\n", res);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zzuli_xiaomingke/article/details/81324852