Jessica's Reading Problem POJ - 3320 尺取法

版权声明: https://blog.csdn.net/nucleare/article/details/89054474

Jessica's Reading Problem

 POJ - 3320  

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

扫描二维码关注公众号,回复: 5884190 查看本文章
2

题意:求最短区间,使得区间覆盖所有知识点,输出区间长度

map做法:

#include <iostream>
#include <cstdio>
#include <map>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;

int a[1000007];
map<int, int> mp;
int main() {
	
	int n;
	while (~scanf ("%d", &n)) {
		int all = 0; //所有知识点 
		mp.clear();
		for (int i = 1; i <= n; ++i) {
			scanf ("%d", &a[i]);
			if (!mp[a[i]]++) ++all;
		}
		mp.clear();
		int tail = 1, head = 0, ans = INF;
		int sum = 0; //知识点个数 
		while(1) {
			while (head < n && sum < all) sum += (!mp[a[++head]]++);
			if (sum < all) break;
			ans = min(ans, head - tail + 1);
			sum -= (!--mp[a[tail++]]);
		}
		printf ("%d\n", ans);
	}
	
	return 0;
}

二分离散做法:快很多 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <algorithm>
#include <vector>
using namespace std;
const int INF = 0x3f3f3f3f;

int a[1000007];
int id[1000007];
vector<int> v;
int getid(int x) {
	return lower_bound(v.begin(), v.end(), x) - v.begin() + 1;
}
int main() {
	
	int n;
	while (~scanf ("%d", &n)) {
		v.clear();
		for (int i = 1; i <= n; ++i) {
			scanf ("%d", &a[i]), v.push_back(a[i]);
		}
		sort(v.begin(), v.end()); v.erase(unique(v.begin(), v.end()), v.end());
		int all = v.size();
		memset(id, 0, sizeof(id));
		int tail = 1, head = 0, ans = INF;
		int sum = 0; //知识点个数 
		while(1) {
			while (head < n && sum < all) sum += (!id[getid(a[++head])]++);
			if (sum < all) break;
			ans = min(ans, head - tail + 1);
			sum -= (!--id[getid(a[tail++])]);
		}
		printf ("%d\n", ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nucleare/article/details/89054474