POJ - 3320 C - Jessica's Reading Problem 尺取法+map

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

 尺取法的一个变式,在原来的基础上讲判定条件修改一下即可....

在这里我用了map表示序列含有元素的种类和个数....

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int maxn= 1000005;
int a[maxn];
int n;
map<int,int>Map,Re;
void Ruler ()
{
   int st=0,en=0,ans=n;
   int Size=Map.size();
   while (1)
   {
       while (Re.size()<Size&&en<n)
       {
           if(Re.find(a[en])==Re.end())
           {
               Re[a[en]]=1;
           }
           else
           {
               Re[a[en]]++;
           }
           en++;
       }
       if(st>en)
         break;
       if(Re.size()==Size)
          ans=min(ans,en-st);
       if(Re.find(a[st])!=Re.end())
       {
           if(Re[a[st]]>1)
              Re[a[st]]--;
           else
            {
                Re.erase(a[st]);
            }
       }
       st++;
   }
   printf("%d\n",ans);
}
int main()
{
    scanf ("%d",&n);
    for (int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        if(Map.find(a[i])==Map.end())
        {
            Map[a[i]]=1;
        }
    }
    Ruler();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/83039745