Jessica's Reading Problem(尺取法)

Jessica’s Reading Problem

Jessica’s a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica’s text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica’s text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

注意: 不要把 p付给 ans,把 inf付给 ans。

完整代码:

#include<cstdio>
#include <iostream>
#include<algorithm>
#include<map>
#include<set>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f3f3f3f3f;
ll a[1000010];
set<ll>st;
map<ll,ll>mp;       //对应每个知识点出现的次数
int main()
{
    ll p;
    cin>>p;
    for(ll i=0;i<p;i++)
    {
        scanf("%lld",&a[i]);
        //cin>>a[i];//这里使用cin真的慢,贼慢 ,很慢
        st.insert(a[i]);
    }
    ll len=st.size();   //知识点的个数
    ll ans=inf;
    ll l=0,r=0;         //左右
    ll sum=0;
    while(1)
    {
        while(r<p&&sum<len)     //不停的向右
        {
            if(mp[a[r++]]++==0)
            {
                sum++;
            }
        }
        if(sum<len)         //sum<len r延申出去了
        {
            break;
        }
        ans=min(ans,r-l);
        if(--mp[a[l++]]==0)     //如果一个知识点不出现了(出现的次数变为0),就减少一个知识点
        {
            sum--;
        }
    }
    printf("%lld\n",ans);
    return 0;
}


不会容器(set和map)的同学可以看一下这个博客: https://blog.csdn.net/qq_45856289/article/details/104506676

发布了60 篇原创文章 · 获赞 69 · 访问量 2824

猜你喜欢

转载自blog.csdn.net/qq_45856289/article/details/104523616