poj 2387。最短路径问题 dijkstra算法

题目:

Til the Cows Come Home

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 47642   Accepted: 16216

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

给了一个无向图,输入t和n, t代表几个顶点,n代表问的是从第一个顶点到第n的顶点的最短距离,各种最短路算法的模板题

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#include<list>
#include<map>
#include<set>
const int INF =0x3f3f3f3f;
const int maxn=1010;
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    int n,t;cin>>n>>t;
    int w[maxn][maxn],d[2010],v[2010];
    int a,b,c;
    for(int i=0;i<t;i++) for(int j=0;j<t;j++) w[i][j]=INF;
    for(int i=0;i<n;i++)
    {
        cin>>a>>b>>c;
        if(c<w[a-1][b-1])
        {
            w[a-1][b-1]=c;
            w[b-1][a-1]=w[a-1][b-1];
        }
    }
    memset(v,0,sizeof(v));
    for(int i=0;i<t;i++) d[i]=(i==0?0:INF);
    for(int i=0;i<t;i++)
    {
        int x,m=INF;
        for(int y=0;y<t;y++) if(!v[y]&&d[y]<=m) m=d[x=y];
        v[x]=1;
        for(int y=0;y<t;y++)
        {
            if(!v[y]&&d[x]+w[x][y]<d[y])
                d[y]=d[x]+w[x][y];
        }
    }
    cout<<d[t-1]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wzazzy/article/details/81110862
今日推荐