POJ-1125 最短路问题,dijkstra算法

Stockbroker Grapevine

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39013   Accepted: 21751

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 
 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

题意:说是一群人要散播谣言,所以选一个人来散播,散播时间要最小,这个人可以同时向自己认识的人散播谣言

第一个输入n   表示有 n 个人   后面接这 n 个人自己认识的人的个数,认识人的编号和散播到他所需要的时间 ,问传播到所有人最少需要多久

扫描二维码关注公众号,回复: 2417881 查看本文章

思路:一开始我用 dijkstra 算法算这个,一直wa(然后POJ日常了......应该不是我干的),后面我去看其他人的博客,都是用  floyd 算法做的.....没找到用 dijkstra 做的,然后我就去看了一下他们的代码......懂了

这道题的做法我是用枚举做的,设每个人都是第一个人,然后传播出去,找到最小值输出就行了

我 wa 的情况是因为我在松弛的时候,我去找最大的一条边,然后让这些全部加起来,至今还不知道怎么 wa 的.....

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=110;
const int INF=0x7f7f7f7f;
int map[maxn][maxn],dis[maxn],n;
bool vis[maxn];
int dijkstra(int x)
{
	int i,j,Min,flag,ans,Max;
	memset(vis,false,sizeof(vis));
	memset(dis,0x7f,sizeof(dis));
	dis[x]=0;ans=0;
	for (i=1;i<=n;i++)
		{
			Min=INF;flag=0;
			for (j=1;j<=n;j++)
				if (vis[j]==true)
					continue;
				else if (Min>dis[j])
						{
							Min=dis[j];
							flag=j;
						}
			if (Min==INF)
				break;
			vis[flag]=true;
			for (j=1;j<=n;j++)
				if (vis[j]==true)
					continue;
				else dis[j]=min(dis[j],dis[flag]+map[flag][j]);
                                        //我就是这里找Max=max(Max,map[flag][j]),然后全部加起来,wa了
		}
	for (i=1;i<=n;i++)
		if (vis[i]==false)
			return INF;
	Max=0;
	for (i=1;i<=n;i++)       //只要把源点到各个点的最短路找到,然后找到最大值就是这个点传播到其他所有人的最短时间
		Max=max(Max,dis[i]);
	return Max;
}
int main()
{
	int i,j,m,flag;
	int u,v,Min,ans;
	while (cin>>n&&n)
		{
			for (i=1;i<=n;i++)
				for (j=1;j<=n;j++)
					map[i][j]=INF;
			for (i=1;i<=n;i++)
				{
					cin>>m;
					for (j=1;j<=m;j++)
						{
							cin>>u>>v;
							map[i][u]=v;
						}
				}
			ans=INF;flag=0;
			for (i=1;i<=n;i++)
				{
					Min=dijkstra(i);
					if (Min<ans)
						{
							ans=Min;
							flag=i;
						}
				}
			if (ans==INF)
				cout<<"disjoint"<<endl;
			else cout<<flag<<" "<<ans<<endl;
		}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/81200620
今日推荐