POJ 2387 Til the Cows Come Home(最短路径Dijkstra)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 71737   Accepted: 23963

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November

最短路径问题,当然想到的是Dijkstra算法。然而却WA了好几次...第一次是没有考虑重边,第二次是在遍历时多写了一次,参见注释......还是不够熟练!要继续练习!!!+

#include <iostream>
#include <cstring>
#include <cstdio>
#define inf 999999999
using namespace std;
int Min, u;
int map[1010][1010];
int dis[1010], book[1010];
int main()
{
	int T, N;
	cin >> T >> N;
	memset(map, 0, sizeof(map));
	memset(book, 0, sizeof(book));
	for(int i = 1; i <= N; i++)
	{
		for(int j = 1; j <= N; j++)
		{
			if(i == j)	map[i][j] = 0;
			else		map[i][j] = inf;
		}
	}
	for(int i = 1; i <= T; i++)
	{
		int x, y, d;
		cin >> x >> y >> d;
		if ( d < map[x][y] )
        	map[x][y] = map[y][x] = d;	//注意重边,要取较短的那条路
	}

    //Dijkstra 核心算法
	book[1] = 1;
	for(int i = 1; i <= N; i++)
		dis[i] = map[1][i];
	for(int i = 1; i <= N-1; i++)    //注意遍历N-1遍
	{
		Min = inf;
		for(int j = 1; j <= N; j++)
		{
			if(book[j] == 0 && dis[j] < Min)
			{
				Min = dis[j];
				u = j;
			}
		}
		book[u] = 1;
		for(int k = 1; k <= N; k++)
		{
			if(map[k][u] + dis[u] < dis[k]&&map[u][k]<inf)
            //!!易错!小于dis[k]且map要小于inf("inf+n > inf" is not admitted)
				dis[k] = map[k][u] + dis[u];
		}
	}
	cout << dis[N];
}

猜你喜欢

转载自blog.csdn.net/blackmail3/article/details/81364431
今日推荐