【算法】最短路径--poj2387 奶牛回家

Til the Cows Come Home
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 67017   Accepted: 22536

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

题目分析:

此题为单源最短路径问题,用dijkstra算法可以解决。

代码:

// POJ2387  ---- Til the Cows Come Home
// 迪杰斯特拉--最短路径问题 
// 从源顶点到达各个顶点,的 最短距离

#include<iostream>
#include<vector>
#include<stdio.h>
#define INT_MAX 0x7fffffff
#define Alone   -1;
using namespace std;


/*
function: Dijkstra(int v,int n,vector<int> &dist,vector<int> &pre,vector<vector<int>> &d)
param:	int v:开始节点
		int n: 节点数
		dist : 距离
		pre : 父辈节点
		d  :  图 
return: void 

注意:1.下标从0还是从1开始? 决定了n/ s(n)/s(n+1)
	  2.孤立节点怎么处理 
		 
*/

void Dijkstra(int v,int n,vector<int> &dist,vector<int> &pre,vector<vector<int> > &d)
{
	vector<bool> s(n+1); // 黑色节点  初始化为 0-白色 
	for(int i=1;i<=n;i++)  //初始化 dist,pre 
	{
		dist[i]=d[v][i];
		if(dist[i] < INT_MAX)
		{
			pre[i]=v;
		}
		else pre[i]=Alone; //未找到父辈 
	}
	dist[v]=0; //开始节点的距离 置0 
	s[v]=true;  //开始节点 染黑 
	
	for(int i=2;i<=n;i++)  // n-1 次循环
	{
		int best=v;
		int temp=INT_MAX; 
		for(int j=2;j<=n;j++) //找到最小距离 
		{
			if(!s[j] && dist[j]<temp)
			{
				temp=dist[j];
				best=j;
			}
		}
		s[best]=true;
		for(int k=2;k<=n;k++)
		{
			if(! s[k] && d[best][k] !=INT_MAX) //k节点为白,且best->k有链路(相连) 
			{ 
				int new_dist=dist[best]+d[best][k];
				if(new_dist < dist[k])
				{
					dist[k]=new_dist;
					pre[k]=best;
				}	
			}
		} 
	}  
}

int main()
{
	//freopen("2.txt","r",stdin);
	int n,m;  //n个节点,m条边 
	cin>>m>>n;
	vector<vector<int> > d(n+1,vector<int>(n+1)) ; //图 路径图(n*n) 
	//vector<vector<int> >  后面两个> > 必须加空格 
	//[Error] '>>' should be '> >' within a nested template argument list
	
	//初始化 图
	for(int i=1;i<=n;i++)  //下标从0开始,无向图 
	{
		for(int j=1;j<=n;j++)
		{
			d[i][j]=INT_MAX; 
		}
	} 
	
	int p,q,value; // p->q
	for(int i=0;i<m;i++ )
	{
		cin>>p>>q>>value;
		if(d[p][q]>value) 
		{
		d[p][q]=value;
		d[q][p]=value; //无向图加此句 
		}
	}
   

	vector<int>  dist(n+1),pre(n+1);
	Dijkstra(1,n,dist,pre,d);

   // cout<<"path: " ;
   //	print_path(pre,0,n);
	cout<<dist[n]<<endl;
	return 0;
} 
 
 


猜你喜欢

转载自blog.csdn.net/u012679707/article/details/80029394
今日推荐