sdut oj 2449 数据结构实验之栈与队列十:走迷宫

数据结构实验之栈与队列十:走迷宫

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

一个由n * m 个格子组成的迷宫,起点是(1, 1), 终点是(n, m),每次可以向上下左右四个方向任意走一步,并且有些格子是不能走动,求从起点到终点经过每个格子至多一次的走法数。

Input

       第一行一个整数T 表示有T 组测试数据。(T <= 110)

对于每组测试数据:

第一行两个整数n, m,表示迷宫有n * m 个格子。(1 <= n, m <= 6, (n, m) !=(1, 1) ) 接下来n 行,每行m 个数。其中第i 行第j 个数是0 表示第i 行第j 个格子可以走,否则是1 表示这个格子不能走,输入保证起点和终点都是都是可以走的。

任意两组测试数据间用一个空行分开。

Output

 对于每组测试数据,输出一个整数R,表示有R 种走法。

Sample Input

3
2 2
0 1
0 0
2 2
0 1
1 0
2 3
0 0 0
0 0 0

Sample Output

1
0
4

Hint

Source

dfs。。

全部遍历就行。

#include <bits/stdc++.h>

using namespace std;

bool Map[10][10];
int v[4][2] = {{1, 0}, {0, 1}, {0, -1}, {-1, 0}};
int n, m, cnt;
void dfs(int x, int y);
int main(){
    ios::sync_with_stdio(0);
    int t, x;
    cin >> t;
    while(t--){
        cin >> n >> m;
        memset(Map, 0, sizeof(Map));
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= m; j++){
                cin >> x;
                if(x)   Map[i][j] = 0;
                else   Map[i][j] = 1;
            }
        }
        cnt = 0;
        dfs(1, 1);
        cout << cnt << endl;
    }
    return 0;
}

void dfs(int x, int y){
    if(x == n && y == m){
        cnt++;
        return;
    }
    int c, d;
    for(int i = 0; i < 4; i++){
        c = x + v[i][0];
        d = y + v[i][1];
        if(Map[x][y] && c >= 1 && c <= n && d >= 1 && d <= m){
            Map[x][y] = 0;
            dfs(c, d);
            Map[x][y] = 1;
        }
    }
}

话说, 把dfs换成下面那个也能过。有点疑问,不需要判断边界吗?

void dfs(int x, int y){
    if(x == n && y == m){
        cnt++;
        return;
    }
    int c, d;
    for(int i = 0; i < 4; i++){
        c = x + v[i][0];
        d = y + v[i][1];
        if(Map[x][y]){
            Map[x][y] = 0;
            dfs(c, d);
            Map[x][y] = 1;
        }
    }
}

猜你喜欢

转载自blog.csdn.net/zx__zh/article/details/82119093