pat-1002 for Polynomials(简单的多项式相加+数组下标的灵活运用)

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main(){
    int k,z,i,count;
    double x;
    double a[1005];
    scanf("%d",&k);
    count=0;
    memset(a,0,sizeof(a));
    while(k--){
        scanf("%d %lf",&z,&x);//数组下标放指数,数组里面放系数
        a[z]+=x;
    }
    scanf("%d",&k);
    while(k--){
        scanf("%d %lf",&z,&x);
        a[z]+=x;//输入了第二组多项式,顺便把指数相同的项相加了
    }
    for(i=1000;i>=0;i--){
        if(a[i]!=0.0){
            count++;//计算总共有几项
        }
    }
    printf("%d",count);
    for(i=1000;i>=0;i--){
        
        if(a[i]!=0.0){
            printf(" %d %0.1lf",i,a[i]);
        }
    }
    printf("\n");
    
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/81532750