PAT A1002 for Polynomials

前言

传送门

正文

题目描述

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1 aN1​​ N2​ aN2… NK aNK

where K is the number of nonzero terms in the polynomial, N​i and aN​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路:

对相应指数的项的系数相加即可,a[i]表示指数为i的项的系数

参考题解:

#include<cstdio>
const int max_len=1001;
int main(){
	int k,m,count=0;
	double a[max_len],n;
	memset(a,0,sizeof(a));
	for(int i=0;i<2;i++){
		scanf("%d",&k);
		while(k--){
		scanf("%d%lf",&m,&n);
		a[m]+=n;
		}
	}
	for(int i=0;i<max_len;i++){
		if(a[i]!=0){
			count++;
		}
	} 
	printf("%d",count);
	for(int i=max_len-1;i>=0;i--){
		if(a[i]!=0){
			printf(" %d %.1f",i,a[i]);
		}
	}
	return 0;
}

后记

独揽月下萤火,照亮一纸寂寞;
追忆那些什么,你说的爱我;
花开后花又落 ,轮回也没结果;
苔上雪告诉我, 你没归来过。

《南山忆》——许嵩

发布了65 篇原创文章 · 获赞 101 · 访问量 9万+

猜你喜欢

转载自blog.csdn.net/qq_40563761/article/details/102845708