PAT甲级1002 多项式相加

题目

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2


题解

#include<iostream>
using namespace std;
int main(){
  float c[1001]={0};// zuida 2 you 3ge shu
  int k,m,n;
  float a;//if n=  axiang+

  scanf("%d",&k);
  for(int i=0;i<k;i++){
    scanf("%d%f",&n,&a);
    c[n]+=a;
    
  }  
  
  scanf("%d",&m);
  for(int i=0;i<m;i++){
    scanf("%d%f",&n,&a);
    c[n]+=a;
  }  
    int count=0;
  for(int i=0;i<1001;i++){
    if(c[i]!=0) count++;
    
  }
  printf("%d",count);
  for(int i=1000;i>=0;i--){
    
    if(c[i]!=0.0){
       printf(" %d %0.1f",i,c[i]);
    }
   
  }
  
  return 0;
}

这里犯得错是printf的格式有问题

猜你喜欢

转载自blog.csdn.net/qq_24572475/article/details/82731221