[PAT甲级]1015. Reversible Primes (20)(可逆素数判断)

1015. Reversible Primes (20)

原题链接
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目大意:

  • 可逆素数判断:一个十进制数 N 在 D进制 下反转后的十进制数仍为素数,则为可逆素数
  • 注意前后均为十进制,只是在D进制下反转

代码:

#include <iostream>

using namespace std;
bool isPrime(int n){
    if(n <= 1)
        return false;
    for(int i=2; i*i<=n; i++){
        if(n%i == 0)
            return false;
    }
    return true;
}
int main()
{
    bool flag = true;
    int n, d;
    while(flag){
        cin >> n;
        if(n < 0)
            break;
        cin >> d;//进制
        if(isPrime(n) == false){
            cout << "No" << endl;
            continue;
        }
        int revers = 0;//D进制下反转后的数
        while(n != 0){//D进制下反转
            int temp = n%d;
            revers = revers*d + temp;
            n /= d;
        }
        if(isPrime(revers) == false){
            cout << "No" << endl;
        }else{
            cout << "Yes" << endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/whl_program/article/details/77688399
今日推荐