PAT甲级1015 Reversible Primes (20 分)

1015 Reversible Primes (20 分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 题目大意:

输入两个数,第一个是数字n第二是radix,如果数字n本身是素数且在radix进制下反转后仍然也是素数则输出Yes,否则输出No。

#include <iostream>
#include <cstdio>
#include <math.h>

using namespace std;

int isPrime(int num)
{
    if(num<=1)return false;
    int n = sqrt(num);
    for(int i = 2;i<=n;i++)
    {
        if(num%i==0)
            return false;
    }
    return true;
}

int Myreverse(int num,int radix)
{
    int len = 0;
    int n[100];
    while(num!=0)
    {
        n[len++] = num%radix;
        num = num/radix;
    }
    for(int i = 0;i<len;i++)
        num = num*radix+n[i];
    return num;
}

int main()
{
    int num,radix,rever;
    while(cin>>num)
    {
        if(num<0)break;
        cin>>radix;
        if(isPrime(num)==false)
        {
            printf("No\n");
            continue;
        }
        rever = Myreverse(num,radix);
        if(isPrime(rever))
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
发布了56 篇原创文章 · 获赞 18 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/103131198