【PAT】A1015. Reversible Primes (20)

Description:
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:
73 10
23 2
23 10
-2


Sample Output:
Yes
Yes
No

//NKW 甲级练习题1027
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
int de[18], len = 0;
bool isprime(int n){
	if (n <= 1)	return false;
	int sqr = (int)sqrt(1.0*n);
	for (int i = 2; i <= sqr; i++)	//这里第一次写的是i<sqr导致结果错误
		if (n%i == 0)
			return false;
	return true;
}
int reverse(int n, int d){
	len = 0;
	do{
		de[len++] = n%d;
		n /= d;
	} while (n != 0);
	int a = 0;
	for (int i = 0; i < len; i++)
		a = a*d + de[i];
	return a;
}
int main(){
	int n, d;
	while(1){
		scanf("%d", &n);
		if (n < 0)	break;
		scanf("%d", &d);
		if (isprime(n) && isprime(reverse(n, d)))
			printf("Yes\n");
		else
			printf("No\n");
	}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81121537
今日推荐