PAT.A1015 Reversible Primes (20)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No
#include<cstdio>
#include<algorithm>
#include<cmath>
bool isprime(int n) {
	if (n <= 1) return false;
	int sqr = (int)sqrt(1.0*n);
	for (int i = 2; i <=sqr; i++) {
		if (n%i == 0) return false;
	}
	return true;
 }
int rev(int n,int rad) {
	int a[111] = { 0 };
	int i = 0,s=0;
	do {
		a[i++] = n % rad;
		n /= rad;
	} while (n);
	//for (int p = 0; p < i; p++) printf("%d ", a[p]);
	//printf("\n");
	for (int j = 0; j < i; j++) {
		s = s * rad + a[j];
	}
	return s;
}
int main() {
	int n, rad,n1=0;
	while (scanf("%d", &n) != EOF) {
		if (n<0) break;
		scanf("%d", &rad);
		n1 = rev(n, rad);
		//printf("%d", n1);
		if (!isprime(n)) printf("No\n");
		else {
			if (isprime(n1))
				printf("Yes\n");
			else
				printf("No\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/mokena1/article/details/80646716
今日推荐