PAT1015 Reversible Primes (20 分)

1015 Reversible Primes (20 分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N ( < 1 0 5 <10^5 ) and D ( 1 < D 10 1<D≤10 ), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No




解析

体会到了甲级和乙级的区别了。同样是水题,但是甲级会让你做更多的事情。也就是一道题考了几个点。




什么是Reversible Primes
这个数是素数的同时,将其转换为D进制的数,再反转,产出的数还是个素数。就是Reversible Primes
又考了素数,又考了进制转换 d=====( ̄▽ ̄*)b



Code:

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
bool isprime(unsigned num) {
	if (num <= 1)
		return false;
	for (int i = 2; i*i <= num; i++)
		if (num%i == 0)
			return false;
	return true;
}
unsigned rever(int num, int radix) {
	string result;
	do {
		result += num % radix+'0';
		num /= radix;
	} while (num);
	int sum = 0;
	for (auto x : result) {
		sum = sum * radix + x - '0';
	}
	return sum;
}
int main()
{
	int N, D;
	while ((cin >> N) && N >= 0) {
		cin >> D;
		if (isprime(N) && isprime(rever(N, D)))
			cout << "Yes" << endl;
		else
			cout << "No" << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/82885747
今日推荐