2128 Problem C How Many Tables

问题 C: How Many Tables

时间限制: 1 Sec  内存限制: 32 MB
提交: 54  解决: 41
 

题目描述

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

输入

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

输出

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

样例输入

2
6 4
1 2
2 3
3 4
1 4

8 10
1 2
2 3
5 6
7 5
4 6
3 6
6 7
2 5
2 4
4 3

样例输出

3
2

经验总结

没什么可说滴,就是经典的并查集算法~~( 。ớ ₃ờ)ھ

正确代码

#include <cstdio>

int father[1010];

int findFather(int a)
{
	int x=a;
	while(x!=father[x])
	{
		x=father[x];
	}
	while(a!=father[a])
	{
		int z=a;
		a=father[a];
		father[z]=x;
	}
	return x;
}
void Union(int a, int b)
{
	int A=findFather(a);
	int B=findFather(b);
	if(A!=B)
	{
		father[A]=B;
	}
}
void init(int n)
{
	for(int i=1;i<=n;++i)
	{
		father[i]=i;
	}
}
int main()
{
	int n,k,no,dot1,dot2;
    while(~scanf("%d",&no))
    {
    	if(no==0)
    		break;
    	for(int x=0;x<no;++x)
    	{
    		scanf("%d %d",&n,&k);
	    	init(n);
	    	for(int i=0;i<k;++i)
	    	{
	    		scanf("%d %d",&dot1,&dot2);
	    		Union(dot1,dot2);
			}
			int ans=0;
			for(int i=1;i<=n;++i)
			{
				if(father[i]==i)
				{
					ans++;
				}
			}
			printf("%d\n",ans);
		}
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a845717607/article/details/81611358